Collection of tools useful for audio production
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

INSTALL.md 2.2KB

10 years ago
10 years ago
10 years ago
10 years ago
10 years ago
12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. # --- INSTALL for Cadence ---
  2. To install Cadence and its tools, simply run as usual: <br/>
  3. `$ make` <br/>
  4. `$ [sudo] make install`
  5. You can run the tools without installing them, by using instead: <br/>
  6. <i>(Replace '&lt;tool&gt;' by a proper name, in lowercase. Some distros may need to use 'python' here)</i> <br/>
  7. `$ make` <br/>
  8. `$ python3 src/<tool>.py`
  9. Packagers can make use of the 'PREFIX' and 'DESTDIR' variable during install, like this: <br/>
  10. `$ make install PREFIX=/usr DESTDIR=./test-dir`
  11. <br/>
  12. ===== BUILD DEPENDENCIES =====
  13. --------------------------------
  14. The required build dependencies are: <i>(devel packages of these)</i>
  15. - JACK
  16. - Qt5
  17. - PyQt5 (Py3 version)
  18. On Debian and Ubuntu, use these commands to install all build dependencies: <br/>
  19. `$ sudo apt-get install libjack-jackd2-dev qtbase5-dev qtbase5-dev-tools` <br/>
  20. `$ sudo apt-get install python3-pyqt5 python3-pyqt5.qtsvg pyqt5-dev-tools`
  21. To run all the apps/tools, you'll additionally need:
  22. - python3-dbus
  23. - python3-dbus.mainloop.qt
  24. Optional but recommended:
  25. - a2jmidid
  26. - jack-capture
  27. - pulseaudio[-module-jack]
  28. The 'Cadence' app relies on jackdbus to work properly (either JACK2 or JACK1+DBus patch). <br/>
  29. Claudia is a LADISH frontend, so it will obviously require LADISH to run.
  30. The python version used and tested is python3.2. Older versions won't work! <br/>
  31. After install, the app/tools will still work on distributions with python2 as default, without any additional work.
  32. <br/>
  33. ===== RUNTIME DEPENDENCIES =====
  34. ----------------------------------
  35. All tools require Python3 and Qt5 (PyQt5), some of them work on Windows and Mac. <br/>
  36. Here's the required run-time dependencies of each of the main tools:
  37. ### Cadence
  38. Requires jack <br/>
  39. Recommends a2jmidid (>= 7) and jackdbus <br/>
  40. Suggests pulseaudio[-module-jack] <br/>
  41. ### Cadence-JackMeter
  42. Requires jack <br/>
  43. ### Cadence-JackSettings
  44. Requires jackdbus <br/>
  45. ### Cadence-Logs
  46. No special requirements <br/>
  47. ### Cadence-Render
  48. Requires jack-capture <br/>
  49. ### Cadence-XY Controller
  50. Requires jack <br/>
  51. ### Catarina
  52. No special requirements <br/>
  53. ### Catia
  54. Requires jack <br/>
  55. Recommends a2jmidid (>= 7) and jackdbus <br/>
  56. ### Claudia [Linux only] <br/>
  57. Requires jackdbus and ladish <br/>
  58. Recommends a2jmidid <br/>