Browse Source

Fix validation; Update/fix dpf-plugins

tags/v1.0
falkTX 1 year ago
parent
commit
918e19c377
3 changed files with 8 additions and 2 deletions
  1. +6
    -0
      build-plugins.sh
  2. +1
    -1
      plugins/dpf-plugins.json
  3. +1
    -1
      setup/versions.sh

+ 6
- 0
build-plugins.sh View File

@@ -43,8 +43,12 @@ function validate_lv2_bundle() {
env LANG=C LV2_PATH="${LV2DIR}" PATH="${PAWPAW_PREFIX}/bin:${PATH}" \
"${PAWPAW_PREFIX}/bin/lv2_validate" \
"${LV2DIR}/kx-*/*.ttl" \
"${LV2DIR}/mod.lv2/*.ttl" \
"${LV2DIR}/modgui.lv2/*.ttl" \
"/tmp/pawpaw-plugin-check/${lv2bundle}/*.ttl" 1>&2

local ret=$?

if [ "${CROSS_COMPILING}" -eq 0 ] || [ -n "${EXE_WRAPPER}" ]; then
env LANG=C LV2_PATH=/tmp/pawpaw-plugin-check WINEDEBUG=-all \
${EXE_WRAPPER} \
@@ -52,6 +56,8 @@ function validate_lv2_bundle() {
fi

rm -rf /tmp/pawpaw-plugin-check

return ${ret}
}

function validate_lv2_plugin() {


+ 1
- 1
plugins/dpf-plugins.json View File

@@ -15,7 +15,7 @@
"PingPongPan.lv2",
"SoulForce.lv2"
],
"version": "d3f38b2b0265dbacd6c97e0df1b1b904d5ef4b31",
"version": "bec7befcde9469bdbc0f7846fe89b82612181edc",
"description": "Collection of DPF-based plugins",
"dlbaseurl": "https://github.com/DISTRHO/DPF-Plugins.git",
"dlmethod": "git",


+ 1
- 1
setup/versions.sh View File

@@ -27,7 +27,7 @@ KXSTUDIO_LV2_EXTENSIONS_VERSION=fae65fbc173cd2c4367e85917a6ef97280532d88
LILV_VERSION=0.24.12
LV2_VERSION=1.18.0
LV2LINT_VERSION=0.8.0
MOD_SDK_VERSION=c95cdc26cb90c3c7bcdf6d706b462127d412fb7b
MOD_SDK_VERSION=ea586664b406340305f2ad840ca5bac6916564b6
MXML_VERSION=3.1
PCRE_VERSION=8.44
SERD_VERSION=0.30.8


Loading…
Cancel
Save