Browse Source

Make plugin deprecated declarations fail in error

tags/2018-04-16
falkTX 8 years ago
parent
commit
10b8fbb510
2 changed files with 2 additions and 2 deletions
  1. +1
    -1
      ports/dexed/source/ParamDialog.cpp
  2. +1
    -1
      scripts/make-project.lua

+ 1
- 1
ports/dexed/source/ParamDialog.cpp View File

@@ -260,7 +260,7 @@ void ParamDialog::setDialogValues(Controllers &c, SysexComm &mgr, int reso, bool
sysexOut->setSelectedItemIndex(idx);
engineReso->setSelectedItemIndex(reso);
showKeyboard->setToggleState(showKey, false);
showKeyboard->setToggleState(showKey, dontSendNotification);
}
bool ParamDialog::getDialogValues(Controllers &c, SysexComm &mgr, int *reso, bool *showKey) {


+ 1
- 1
scripts/make-project.lua View File

@@ -80,7 +80,7 @@ function make_plugin_project(name, spec)
package.target = project.name
package.targetprefix = ""
package.objdir = "intermediate"
package.buildoptions = { "-Wall", os.getenv("CXXFLAGS") }
package.buildoptions = { "-Wall", "-Werror=deprecated-declarations", os.getenv("CXXFLAGS") }
package.links = {}
package.linkoptions = { os.getenv("LDFLAGS") }



Loading…
Cancel
Save